Sunny
68°
Sunny
Hi 71° | Lo 42°

‘Heartbleed’ flaw leads security experts to urge password changes

Security experts are urging consumers to change their web passwords after the recent disclosure of a vulnerability touching wide swaths of the internet, even as Google, Facebook and large banks said they weren’t affected.

The flaw to OpenSSL, an open-source software that runs on as many as two-thirds of all active websites, was reported Monday by researchers who pushed out a fix. Dubbed “Heartbleed,” the bug could have allowed hackers to access encrypted email messages, banking information, usernames and passwords.

“The one saving grace with this flaw is that it was relatively simple to spot and as a result very simple to fix,” Zully Ramzan, chief technology officer of Elastica, a cyber-security firm, wrote in an email yesterday. “That said, OpenSSL is incredibly widespread. It’s literally the most popular implementation of SSL on the planet. So any compromise in its security has far-reaching implications.”

The Heartbleed revelation comes at a time of mounting concern about hackers’ capabilities following consumer data breaches at Target and Neiman Marcus and the spying scandal involving the National Security Agency. The flaw involving a two-year-old programming mistake was discovered by researchers from Google and Codenomicon, a security firm based in Finland, and reported to OpenSSL, according to a blog post from Codenomicon.

It isn’t known whether malicious hackers knew about the bug and were exploiting it, the researchers wrote. Google and Facebook said they addressed the problem before it was made public and saw no signs of vulnerabilities, while Yahoo! Inc. made the requisite fixes.

“A vulnerability, called Heartbleed, was recently identified impacting many platforms that use OpenSSL, including ours,” Yahoo said in an emailed statement. “Our team has successfully made the appropriate corrections across the main Yahoo properties,” such as the homepage, email, finance and sports sites, the Sunnyvale, Calif.-based company said.

OpenSSL is used by internet companies to secure traffic flowing between servers and users’ computers. SSL refers to an encryption protocol known as Secure Sockets Layer, and its use is indicated by a closed padlock appearing on browsers next to a website’s address.

Before Yahoo issued its fix, security researcher Mark Loman from the Netherlands demonstrated Tuesday on Twitter that he was able to force the site to leak usernames and passwords.

“It wasn’t Yahoo’s fault, yet they’re very slow at installing the critical fix,” Loman wrote on his Twitter Inc. account. “Bug disclosure was flawed too.”

Many large consumer sites running OpenSSL aren’t vulnerable to being exploited because they use specialized encryption equipment and software, the researchers wrote. A test site allows website administrators to check whether their properties are affected.

“The security of our users’ information is a top priority,” Google said in a statement yesterday. “We proactively look for vulnerabilities and encourage others to report them precisely so that we are able to fix them before they are exploited. We have assessed the SSL vulnerability and applied patches to key Google services.”

In a statement, Facebook said it “added protections for Facebook’s implementations of OpenSSL before this issue was publicly disclosed, and we haven’t detected any signs of suspicious activity on people’s accounts.”

JPMorgan Chase & Co., the largest U.S. bank, doesn’t use the vulnerable software and user information has not been exposed, the New York-based company said in a statement.

Tests on the home pages of other large technology, e-commerce and banking companies including Microsoft, Amazon and Bank of America indicated they weren’t vulnerable.

There are no comments yet. Be the first!
Post a Comment

You must be registered to comment on stories. Click here to register.